الجمعة، 10 يوليو، 2015

حل مشكلة ارتفاع البنج في سيرفر الميكروتك والشبكات اللاسلكيه والقضاء علي Request timed out

بسم الله الرحمن الرحيم
السلام عليكم ورحمة الله وبركاته
مشكلة ارتفاع البنج (ping) 
and Request timed out 
 الـping هو امر من اوامر نظام التشغيل Dos
ويستخدم لغرض فحص الاتصال والتأكد منه عن طريق ارسال حزمة بيانات 
الي الجهاز او الاتصال المراد فحصه ثم يقوم بعد ذلك بعرض النتيجه
ويتحكم في ذلك الوقت بين سرعة الارسال والاستقبال وسيط الاتصال او الاجهزه الوسيطه
(مثل الكابلات - الاكسسات - كروت اللان - حجم البيانات المرسله والمستقبله)
كما يمكن من خلال هذا الامر
PING localhost
او
PING 127.0.0.1
فحص كارت اللان الخاص بالجهاز هل يوجد به مشكلات ام لا
ونجد ان نتيجة الفحص منذ لحظة ارسال الباكت حتي رجوعها هو 1 ثانيه وذلك لفحص الجهاز نفسه
اما اذا اردت ان تفحص الاتصال بين الروتر (مودم الـadsl) وجهاز الكمبيوتر تجد ان هناك نتيجتين

اما ان يعطيك الجهاز Request timed out وهذا يعني انه لايوجد رد من الجهاز المرسل اليه الباكت
او تجد ان وقت رجوع الرد اكبر من 1 ثانيه وهذا طبيعي
هذا نجده مختلف تماما اذا اردنا ان نفحص جهاز علي شبكه خصوصا الشبكات اللاسلكيه
تجد انه يوجد كثير من الوقت للرد علي الجهاز الاخر كما يوجد ايضا Request timed out في الرد علي البيانات المرسله
وهذا مايسبب تقطيع في خدمة الانترنت وايضا ظهور المثلث الاصفر علي كارت الشبكه 
وتكمن هذه المشكلات المسببه لارتفاع البينج في الميكروتك او في الشبكات عموما في
 (ضعف الاشاره بين جهاز الارسال والاستقبال - كذلك كثرة الاتصالات - مشاكل في الكابلات او كروت اللان - كثرة استخدام تردد 2.4 جيجا هيرتز نظرا لعدد القنوات المحدود الموجود به لذلك تجد الكثير يستخدم نفس القناه وهذا مايسبب النويز علي الاشاره والاجهزه )
من خلال كل الكلام اللي فات ده تقدر تقول ان حل مشكلة ارتفاع البنج في جودة الاشاره والتردد بين الجهاز المرسل والمستقبل
اما من خلال تظبيط البنج من خلال سيرفر الميكروتك جبت ليكم سكربت جميل جدا في حل هذه المشكله
كل اللي عليك هتحمل الاسكربت وتنزله علي السيرفر من خلال New Terminal
لتحميل الاسكربت
لاتنسونا من صالح دعائكم
والانضمام للموقع


شارك هذه الصفحة وتابعنا على صفحاتنا الرسمية
شارك الموضوع →
تابعنا →
إنشر الموضوع →

5 التعليقات :

  1. السلام عليكم
    بارك الله فيك على الشرح القيم
    استاذ انا عملت مثل كلامك بخصوص تقليل الping
    بس مانفع معاي

    ردحذف
  2. هو السكريبت دا لنسخه مكروتك كام لانه منفعش معايا على النسخه 5 مش بتقبله اصلا

    ردحذف
  3. أخيرا وبعد عناء وتجارب عديدة . تم التوصل الى سكريبت ضبط البنج الخاص بالنسخ 6.xx وهو يعمل فقط على هذا الإصدار . اليكم السكريبت :

    /ip firewall mangle
    add action=mark-packet chain=postrouting new-packet-mark=packet_ip passthrough=yes protocol=icmp

    /queue simple
    add bucket-size=0/0 name=ping-ip packet-marks=packet_ip priority=1/1 queue=default/default target=""

    ملاحظة : لا تقم بعمل اي تعديل اخر في الكيوز وخصوصا في الكيوز تايب اتركها كما هي ولا تقم بتعديل pfifo الى sfq . اما بالنسبة للسكريبت الخاص بالكيوز سيمبل ارفعه الى أعلى القائمة واجعله في المقدمة

    ردحذف
  4. امام بخصوص النسخ 5
    /ip firewall mangle
    add action=mark-connection chain=postrouting comment="Ahmed elaraby QoS OF PING" disabled=\
    no new-connection-mark=ping-ip passthrough=yes protocol=icmp
    add action=mark-packet chain=postrouting comment=" Ahmed elaraby QoS OF PING" \
    connection-mark=ping-ip disabled=no new-packet-mark=packet_ip \
    passthrough=yes



    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name="IP QoS output" packet-mark=packet_ip parent=global-out \
    priority=1 queue=default

    ردحذف

افلام اون لاين